Oops! It appears that you have disabled your Javascript. In order for you to see this page as it is meant to appear, we ask that you please re-enable your Javascript!

Reply To: gps with pic 18f4520

Home Forums MPLAB XC8 Tutorial Discussions gps with pic 18f4520 Reply To: gps with pic 18f4520

#2578

Bitahwa Bindu
Keymaster

They must be some incompatibility of peripheral libraries with XC8 v1.41. That is why it’s giving that error. We tried your code with XC8 v1.34 it compiles well without any problem. As you are aware microchip is phasing out the peripheral libraries, they want people to use the new MPLAB Code Configurator, they are no longer updating the peripheral libraries and thus might not be compatible with new compilers. We would advice you to download XC8 v1.34 under the: Download archives

 

  • This reply was modified 1 year, 3 months ago by  Bitahwa Bindu.