Oops! It appears that you have disabled your Javascript. In order for you to see this page as it is meant to appear, we ask that you please re-enable your Javascript!

Reply To: rs232 serial communication

Home Forums MikroC Pro for PIC Tutorial Discussions rs232 serial communication Reply To: rs232 serial communication

#3847

Bitahwa Bindu
Keymaster

Hi.

Your configuration is incorrect. You are enabling the MCLR but you are not connecting it to VCC. Or you must disable it in Project Menu –> Edit Project. See the attached screenshot.

When you fix this error, your PIC will run but you will receive wrong characters on your USART terminal because:

  1. You must set the Virtual Terminal Baud rate the same as the baude rate you set in your code.
  2. The OSCCON=0x76; is incorrect for 8MHz, please read your PIC datasheet on page 28. It should be 0x66 or 0x67

 

 

Attachments:
You must be logged in to view attached files.